5

enter image description hereenter image description here

I am new to QGIS but have some familiarity with other GIS software (namely ArcGIS). I want to merge a number of LiDAR digital elevation model (DEM) tiles (specifically, 30 individual tiles) to create one large mosaic DEM. All the DEMs are .img files downloaded from this site.

From the QGIS home workspace, I go to Raster > Misc. > Merge. I am careful to type appropriate input and output directories, file names, and file extensions. QGIS completes the merging process, but the mosaic is pitch black and it's min/max values are both a very negative value (both the min and max are -3.40282e+35). Obviously, this mosaic isn't quite right. I am uncertain where I go wrong in my procedure.

I have experimented with writing the output file extension as .img and .tif. I have also experimented with the "No data value" option (leaving this option unselected and trying this option selected with a value of 0). These changes do nothing to the change/improve the final output file issue. I have also attempted to use the mosaic feature on just a 2-by-2 chunk of the individual DEM tiles, but this yields in the same erroneous result.

I am using QGIS 2.4-Chugiak on a Mac running OS X 10.9.4.

  • Could you post a screenshot of the configuration you are using? Please also post the file path to where the rasters are stored. – underdark Sep 7 '14 at 8:03
  • Hi, underdark. I edited the original post, attaching a snapshot of the tile configuration. The directory to where the files are stored on my computer is the following: /Users/samuelstreeter/Desktop/wmnf-2011-bare-earth-dem/data_files/. – Sam Sep 7 '14 at 23:36
  • Oh, forgive me. I think I understand your question now, underdark. The rasters are stored at the following URL: lidar.unh.edu/map. Under the Data Layers heading on the right side of the page, click White Mountain National Forest. Then click the 1. 2011 - Bare Earth DEM. Next, I select the "Search" button in the upper left corner of the map window. This allows one to manually select the swath of tiles that one wants to download. ... I hope this clarifies! – Sam Sep 8 '14 at 15:23
  • I actually meant a screenshot of the Merge dialog. Maybe we could spot something in the settings you used. The file path you pasted should not be an issue. I currently don't have time to download and test the data though. – underdark Sep 10 '14 at 14:23
  • 2
    Possible duplicate of Is there any way to 'clean' up ASTER v2 DEM data? – Andre Silva May 17 '18 at 18:03
3

I had the same problem. To fix it, take a look at the minimum and maximum values of each raster you're merging in the Layers Panel and then input those values into the min and max of your new mosaic raster.

For example: in my LiDAR map project, the lowest minimum value of all my rasters was 1.4998 and the highest maximum value of all my rasters was 63.3014 (these values are visible under the layer name in the Layers Panel). I double-clicked my mosaic layer in the Layers Panel to reveal the Layer Properties window. Next, I input these values as the Min and Max values in the "Band rendering" section, which fixed my mosaic raster and made it look as expected.

Hope this helps, and best of luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.