2

In playing around with adding the Navigation Toolbar Widget to the CMV I noticed the zoom box doesn't show when dragging a box to zoom in/out in IE10 (the red box). It works as expected in Firefox, Chrome and Safari. I don't see an obvious issue. I'm curious if others have seen/resolved this or have any thoughts on where I may look to resolve the issue?

2

I am pretty sure you are referring to the Navigation Toolbar widget which is a contributed widget and not a core CMV widget.

That widget is based on an ESRI sample demonstrating map navigation tools using core JavaScript API functionality for the map navigation. It appears this is a bug with IE10 and IE11 that was recently verified in the current version 3.10 of the API (and several previous versions apparently). That geonet thread suggests the core issue is with the version of Dojo used with the API and it will be fixed in the next release. There are several work-arounds mentioned in that thread and in some of the other threads that it links to. If you try some of those work-arounds, please let me know if any of them solve your issue.

  • 1
    Forcing IE10 into an earlier rendering engine using the X-UA-Compatible meta tag (Firefox, Chrome, etc. will ignore this tag), as suggested in one of the links, works for me. I replaced content="IE=edge" with content="IE=9" in index.html. – user3799279 Sep 22 '14 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.