2

I'm trying to install qgis-mapserver on my ubuntu 12.04. I just installed qgis desktop 2.6.0-brighton successfully. Here is my steps when installed the desktop :

sudo apt-get install python-software-properties 
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable 
sudo apt-get update 
sudo apt-get install qgis python-qgis qgis-plugin-grass

But when I tried to install the mapserver :

sudo apt-get install qgis-mapserver libapache2-mod-fcgid

I got this error :

The following packages have unmet dependencies:
qgis-mapserver : Depends: qgis-providers (= 2.4.0-0precise2) but 2.6.0-0precise1 is to be installed
  • Using a "unstable" branch will could give you this kind of problems. I recommed you use (if you can, of course) "ppa:ubuntugis/ubuntugis-stable" as repository, instead. – Taber Nov 6 '14 at 9:46
2

The package is called "qgis-server" (no "map" part anymore) now.

1

sudo apt-get install qgis-server

  • 1
    Welcome to the site abelouch. It is highly recommended to add context to answers so that future readers can benefit from your post. Otherwise, consider creating a comment. To get fully up-to-speed on how GIS SE works, you can take the tour: gis.stackexchange.com/tour – Aaron Nov 6 '14 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.