0

I am using GeoServer 2.5.

I am having some trouble setting my data directory on Windows server 2012. currently the default is " C:\ProgramData\Boundless\OpenGeo\geoserver " I have gone through the steps here which tell you to set an environment variable which I have followed and used both relative and absolute paths. I have restarted both geoserver and the server after each attempt with no luck.

what I want to do is change the data dir from what it currently is to D:\geoserver where i have copied the schema from the c drive.

Has anyone else experienced a similar problem and if so can you send me in the right direction?

Here is an image of what the env. variable looks like

enter image description here

0

1 Answer 1

6

So the environment variable you're setting is a "User Variable". It applies only to the user you're editing it as.

You need to edit the environment for at least the user that your geoserver is running as. See http://technet.microsoft.com/en-au/library/cc772047.aspx for how to set an environment variable using GPOs. Probably the easiest way is to just make it a system variable. From that TechNet site:

System Variable

To cause the environment variable to affect all users of the computer, select this setting. The environment variable is stored in the registry in HKEY_LOCAL_MACHINE.

The less preferred, but probably easier option is to do it from the screen you've shown above, but click the "New..." from the System variables, not User variables for ... groupbox. You should see it come up with Edit System Variable.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.