4

Google Satellite will not zoom. Although the scale changes as I zoom, as the map is re-rendered, it zooms out to its maximum extent every time.

This first happened in the latter part of November 2014 and I was able to fix it using unibasil's answer Misplaced Google Maps with OpenLayers plugin in QGIS?.

Unfortunately, Friday morning it started happening again. I can no longer zoom on any Google maps (Physical, Street, Hybrid, or Satellite). Although Bing maps work fine, Bing is not as up to date as Google maps.

Currently I am using QGIS 2.2 with the latest OpenLayers 1.1.4 that will work with that QGIS version. I also installed the newest version of QGIS 2.6.1 which uses OpenLayers 1.3.5 and it also will not zoom on any Google Maps.

I tried uninstalling and re-installing the OpenLayers plugin several times with same results. I also tried recopying the OpenLayers.js file as recommended by Unibasil (see above) with no success.

One more interesting clue is that my friend, who also uses Google Maps in QGIS 2.2, is not having this problem. The only difference I can tell is that he has not logged out of QGIS or removed the Google Satellite layer since last Thursday. I unfortunately log out every night. I believe if he were to remove and add Google Satellite layer, it would not be able to zoom either.

I have searched and have not found any recent posting on this problem. The couple old posting I have found do not solve the problem. I hope someone can help.

  • I have the same behavior. Working with anything else but google layers works ok – Gerardo Jimenez Dec 22 '14 at 20:17
  • I cannot confirm this behavior on Ubuntu with QGIS 2.6.1 and OpenLayers 1.3.5 – underdark Dec 23 '14 at 10:39
  • See: "open-layer-plugin-in-qgis-2-6-1-crashes-and-errors-with-zoom" gis.stackexchange.com/questions/127175/… – John Dec 27 '14 at 14:39
0

Open Layer 1.3.6 finally seems to have solved the problem.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • I was also facing the problem with google satellite map as it was not zooming properly with the same scale as other shapefiles. Now there is a new update to open layer plugin (1.3.6) which has fixed that problem. I updated to this version and it worked perfectly for me. – Navin Feb 23 '15 at 15:15
2

After seeing underdark's comment, I tried using Ubuntu with QGIS 2.4. At first it didn't work, but after reinstalling openlayers, I was able to load Google Satellite and zoom in. But I couldn't zoom in past 1:2300 on Bing maps.

So I did some more searching and found a post on QGIS project wiki - http://hub.qgis.org/issues/11728#change-58357 - that indicated that the problem may have something to do with using the 64bit version of QGIS. After reinstalling QGIS 2.2 32 bit version, the problem solved and I am now able to zoom on Google Maps.

I need to be able to zoom in close (1:100) on both Bing and Google. Using QGIS version 2.2 I can zoom into a scale of 1:1000 on Bing maps while QGIS 2.4 or 2.6 only allows me to zoom to 1:2300 on Bing. Maybe this has more to do with the version of openlayers. QGIS 2.2 uses openlayers 1.1.4 while QGIS version 2.4 uses openlayers 1.3.5.

1

I tried Terry's (thank you!) solution on my MAC and on my PC (windows).

Terry's solution works fine on windows, although slower than on more recent versions of QGIS. Make sure to download the 32 bit version of QGIS! As stated by Terry, the 64 bit version will not work with the openlayers plugin.

For MAC users, QGIS can only be downloaded in the 64 bit version and the openlayers plugin will therefore not work properly. If you are using a mac, you can use other satellite imagery or you can another trick that I found here on any version of QGIS.

1

There seem to be a string of questions posed which seek resolution of problems with the OpenLayers and [often] Google Satellite.

I thought I had landed on what seemed to cure the problem: After creating the layer using Google Satellite, I moved that layer to the bottom, as a base map. After that, the pan and zoom issues seem to disappear. I am using QGIS 2.6.1 64k on Win 8, with OpenLayers 1.3.5.

At the end of my work, I closed and saved the project. The next morning, I opened the project and discovered that the google satellite layer, will only display the full earth view, and will not settle on the region of the other layers. I played with closing/opening the project, turning off other layers, and it gets all funky. The programmer in me is not soothed by the non-reproducible nature of this bug, in the various forms it presents itself

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.