2

Yesterday, I successfully installed pgrouting from the most recent x64 2.0.0 binaries, at least this is what I thought. I was able to perform first query - select pgr_createTopology() from the tutorial i was following (http://anitagraser.com/2013/07/06/pgrouting-2-0-for-windows-quick-guide/) . On the next step (step 4 from tutorial), however, I received an error:

ERROR: cannot load library "C:/Program Files/PostgreSQL/9.4/lib/librouting.dll": The specified module could not be found.
SQL state: XX000

I copied downloaded files to PSQL folder again, but it did not help. I found out they have been "blocked" by windows security module, so spent some time learning a new trick on how to unblock them. Finally, after making sure all the files are at the correct places, I did a DROP on pgrouting extension hoping to reinstall it with with replaced files. However, this time even create EXTENSION pgrouting; fails, resulting with the same error as above.

I assume my steps were not necessairly correct since select pgr_createTopology() actually worked, so librouting.dll was probably fine. But nothing explains why subsequent SQL query (with pgr_dijkstra()) prompted an error to librouting.dll file?

Do you maybe have any thoughts on that? I have installed PSQL, PostGIS, pgrouting with the latest files for x64 Win7 as discrepancies between versions were mentioned as a probable cause of such error in Installing PgRouting.

  • 1
    I maintain the windows PostGIS and pgRouting packages. Did you install PostGIS/pgRouting via stackbuilder or just copied from the winnie the windows bot? The PostgreSQL 9.4 PostGIS install includes pgRouting 2.0.0 so you might just want to reinstall via application stackbuilder to make sure you have the latest dlls. Also what do you get when you do SELECT * FROM pgr_version(); I did upgrade my chain midway so that could be causing you problems if you are using older chain file with new dlls. Reinstalling from stackbuilder should fix though – LR1234567 Dec 30 '14 at 23:35
  • I indeed have installed postgis via stackbuilder and noticed pgrouting was already there when I was copying downloaded files manually into PostreSQL folder. Maybe this additional manual intervention broke things as you suggested, as now everything works just fine. I have reinstalled postgis via stackbuilder. Reinstall failed, as the extension was already there, but files were probably replaced anyway. And after that, create extension command worked this time perfectly and other commands seem to work as well, thank you. – user2530062 Dec 31 '14 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.