I am working on satellite images. The region I am interested in is only a fraction of the whole satellite images. My laptop slows down tremendously when working on the whole image. So I clipped the images. Now I want to use the semi automatic classification plug in for classification but revive the following error message:

Error [8]: No metadata found inside the input directory (a .txt file whose name contains MTL)

I tried copying the original file which came with the original sized images when downloading into the folder of the clipped ones. This did not help. How can i generate a new metadata file or work around this problem?

  • 1
    You should post your comment as an answer rather than a comment. If you believe the question and solution may be helpful to others in the future, it's ok to answer your own question.
    – Chris W
    Commented Feb 15, 2015 at 20:29
  • The answer above works perfectly, but it's crucial that the cliped raster files have the exactly same name as the original one
    – user49287
    Commented Mar 20, 2015 at 12:28

1 Answer 1


I solved it on my own but maybe handy for others. First i clipped the layers using Raster-extraction-clipper tool and than copied the .txt file into the folder of the clipped images. This did not work. I now clipped them using the clip multiple raster option within the semi automatic classification plug in and then copied the .txt file from the original images into the folder of the now clipped images and the pre-processing worked fine!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.