0

On my testing machine I experience no problems with using

http://developers.arcgis.com/javascript/samples/featuretable/

but if I run the same example on my client's machine I get "'require' is undefined".

I also experience the same issue with all of their 3.12 examples. Only 3.1 examples seem to work on my client's machine.

Update: It also works just fine in FF and Chrome on client machine

  • require missing is definitely linked to Dojo. Did you install the API locally? – BritishSteel Feb 25 '15 at 20:07
  • nope, it's getting it all from the web. – TruthOf42 Feb 25 '15 at 20:19
  • Have you tried it using different browsers? Your client's browser might be blocking Dojo for some reason. – BritishSteel Feb 25 '15 at 20:30
  • it works fine in FF and Chrome. Is there something I can do to check if IE is blocking dojo in some way? – TruthOf42 Feb 25 '15 at 20:49
  • So it only happens in IE? Depending on what version it is you can hit F12 and open the developer tools. You should also probably search the internet about Dojo not working in that version of IE. – BritishSteel Feb 25 '15 at 20:56
1

I found the cause:

I had to enable "Active Scripting" in Tool -> Internet Options -> Security Tab -> Custom Level

I also had to run-as-administrator IE to be able to change those settings.

I'm surprised that there wasn't an issue when running version 3.1 of ESRI's API.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.