1

I got excellent results while exporting vector layer with styling through qgis2leaf plugin. Whereas when I try to do the same with a geo-referenced raster file (geotiff) which has a projection of EPSG:4326, I am getting a Python Error. I tried reprojecting it to EPSG:3857, even tried changing the format of raster file, but getting the same error. here is a screenshot of the error Screenshot of Python Error Message

Is there any additional GDAL Framework which needs to be installed / updated? Any guidance would be of great help as i am trying to have a transparent existing land use map over OSM to check disparities.

Abhijit

1

Unfortunately this is an issue in the current version. We created this function and it worked well (at least on my linux notebook) and it went down some months ago. You can contribute to this issue

Nevertheless you can reproject any raster to EPSG 4326, translate it to jpg and embed it by hand in your webmap project.

I solved this issue now and you can get the newest version from github or wait until we released a tested version to the official plugin repo.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.