I need to create a new sde service with the command line for the first time with mssql on ArcGIS Server 10.0 so that 3rd party software can access it. Direct connect will not work unfortunately.

As far as I can understand I need to do the following:

  1. sdeservice -o create -d SQLSERVER -p spatial.data -i esri_sde -H z:\arcgis\arcsde\sqlexe
  2. manually edit %windir%\system32\drivers\etc\services and %SDEHOME%\etc\services.sde

How could I find out which port numbers should I use?


5151 is the standard. you are welcome to select any port that is open by editing the services.sde file and adding it, or alternatively remove the comment mark # from the default entry.
Help can be found on the esri website.

10.1 MS SQL Server help

| improve this answer | |

It isn't strictly required to alter the services or services.sde file with SQL-Server, and if you don't specify a port or mnemonic with the -i flag at step 1, then step 2 is completely unnecessary (since it's too late to change from the default of esri_sde 5151/tcp). In fact, best practice is to add non-standard services entries before sdeservice -o create.

You left out using sdeservice to register the Admin_database key (required from command-line with SQL-Server for correct operation), which is why there's a GUI postinstaller -- to make sure critical things don't get missed.

| improve this answer | |
  • I am using an SDE which has already been set up with a number of services. I just want to know how to add new services. We are using 10.0 with sde 9.3 by the way. Do I still need to run the postinstaller for every new service? – Robert Buckley May 8 '15 at 6:44
  • Those are very important details, which make this a very different question -- Your question fails to note that you need to create a new database and a new geodatabase. You cannot use 10.0 tools to make 9.x geodatabase services, and there is no supported mechanism to install 9.x software with 10.x server components installed. – Vince May 8 '15 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.