3

I have just installed service Pack 3 for ArcGIS 10 Desktop. Normally I use the new snapping environment, so I am unsure whether this is a new issue with SP3 or if it has been the case the whole time.

I want to cut a polygon in layer 1 using a trace on overlapping polygons from layer 2. So to be sure I wasn't accidentally snapping to the wrong layer (as there are various other lines and points in the map), I turned on classic snapping and have only the edge in layer 2 selected.

The trace is still following other lines and edges, totally ignoring my classic snapping settings. Has anyone else come across this, or do you know if it is a bug?

  • if I'm not mistaken, previously trace only used the topological editing settings. now in 10 it uses the new snapping. If you switch to classic snapping you would have to use the topological editing toolbar to utilize trace snapping. I could be wrong but this is my opinion. You could try making layer 2 and 1 the only 2 selectable layers. – Brad Nesom Oct 21 '11 at 16:10
  • Making them the only selectable layer has made no difference. If I only have two layers in the map, it will happily trace either of them, despite specifying only one in classic snapping. – Loz Oct 25 '11 at 0:28
3

If you select the line you want to trace, then activate the trace tool>right click>trace options>trace selected features, you should be able to do what you need regardless of what snapping environment you are using.

3

You can also select the poly or line that you want to trace around and then when you go to activate the tool hold down the ctrl key and click where you want to start the trace. By holding down the ctrl key it will only trace along selected features.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.