0

I downloaded the point sampling tool for QGIS and I'm trying to run it. A few days ago it worked fine, but now it gives the following error:

An error has occured while executing Python code:

Traceback (most recent call last):

File "C:...pointsamplingtool \doPointSamplingTool.py", line 262, in accept

   self.sampling(outPath)

File "C:....pointsamplingtool\doPointSamplingTool.py", line 315, in sampling

   if pointGeom.wkbType() == QGis.WKBMultiPoint:

AttributeError: 'NoneType' object has no attribute 'wkbType'

Python version: 2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)]

QGIS version: 2.10.1-Pisa Pisa, d20c5b7

Does anybody know how to fix it?

  • What are your points stored as? Data type? There is something wrong with them. – HeikkiVesanto Jan 3 '18 at 10:29
2

I had the same I was trying to get point sample working in data extracted from CSV file and raster file Solved by:

Saving the data from CSV file as shapefile then create the point sampling against the shapefile and the raster data and it worked fine .

hope this help u :)

1

This looks like a bug in the plugin. I would suggest to open an issue report. Please note that gis.se is not a bugtracker and it is unlikely that this post here will help to fix this issue.

For further possibilities to proceed, please have a look at this answer.

  • Thanks - was hoping that somebody else would have had the problem and know how to fix it. – Sam Aug 29 '15 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.