2

I am running on MAC OSX El Capitan. My version of postgres is 9.4.5.0. My PostGIS version is 2.1.7. I cannot upgrade to PostGIS 2.2, because when I am trying to do, it pops "PostGIS requires SFCGAL >= 1.1.0 (found 1.0.5)". Than when I try to fix it by upgrading SFCGAL, it stops process in the steps of compiling "union.cpp" library. I have found on github, that the problem might be in the old version of Boost, so I have upgraded Boost, but the problem has preserved.

  • Which version of Boost are you using? If you are compiling SFCGAL yourself, I would suggest using 1.2.0+. 1.1.0 has compile issues with newer Boost. – LR1234567 Oct 29 '15 at 19:48
  • I am using boost 1.58 - almost the most recent one. And still unsuccessful with upgrading sfcgal. – Michael Knave Oct 30 '15 at 9:41
  • Yah 1.58 doesn't work with 1.1.0 SFCGAL. Try compiling with 1.2.0 SFCGAL. Though I think booset 1.59 might work. Here is related ticket - github.com/Oslandia/SFCGAL/issues/103 – LR1234567 Oct 30 '15 at 13:02
  • I have problem, when I compile v1.59 it still uses v 1.58. – Michael Knave Oct 30 '15 at 14:02
  • Did you try using 1.2.0 SFCGAL. 1.2.0 should work fine with 1.58 and has a lot of bugs fixed that existed in 1.1.0 – LR1234567 Oct 30 '15 at 14:29
1

I should also mention, if you don't need SFCGAL support you should be able to turn off with

./configure --without-sfcgal

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.