I'm right now working with navteq data and building 'the XML-File' to generate the tiles!

I started with an all original osm.xml, and set all the status' to "off". First I checked the dataset in my database with SRID(the_geom) and got a return "SRID:4326". So I set up the layer to SRID4326 instead of SRID900913.

<Layer name="myLayer" status="on" srs="+init=epsg:4326">

My pgSQL query was written according to the OSM query:

(select the_geom, 'true' as "water", polygon_nm as "name"
      from waterseg ) as myLayer

The next step was to setup the stylesheet. I did that - set the max and min zoom level to the maxima. So the zoomlevels should influence the rendering.

But it's not working. I can't see a single stroke on the image. I just get an empty picture. I tried to look through the file and see if there is any problem with a potential z-level - don't think so. Next was to check the bounds - no matter if I set bounds as 900913 or 4326 the image is still the same.

I assume strongly, that I have somewhere a problem with the projections. Can anyone help me? Has anyone ever tried to render a full map from scratch, without the predefined stylesheet!


2 Answers 2



Have you remembered to also set the Map level srs to "+init=epsg:4326"? Also, you need to explain how you are actually rendering the image otherwise it is hard to help further. I recommend using nik2img which has a --verbose flag and get help you understand when you've mixed up coordinate systems and/or the map bounds.

  • Problem was solved a long time ago, thx Dane - poped up this morning in my inbox. thx anyway ;).
    – Styp
    Commented May 28, 2014 at 17:57

the problem is your projection setting.

set the layer srs with 4326. and set map srs with any projection you want to generate map .

map srs :

srs: Coordinate system in which the map is rendered (for instance '+proj=latlong+datum=WGS84' for a WGS84 Geographic coordinate system)

layer srs :

srs: Default inherits from map.srs; Reference system from the the project Proj.4. e.g. +proj=latlong +datum=WGS84

take a look at Mapnik XML Documentation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.