1

I'll use the import extension to import a KML file. When I go to Layer Preview and use the OpenLayers option (basically, a WMS GetMap url), it displays. When I try to use the url in a browser and I'm not logged in, however, I get "Could not find layer". Same result when I use WFS with OpenLayers -- the layer shows up if I'm logged in to GeoServer, doesn't show up otherwise.

I've installed this through the geonode package from the geonode/stable ppa onto Ubuntu 14.04. All of the settings are default. I can view layers and vectors uploaded through GeoNode without being logged in to GeoServer, but using GeoServer's import extension is what leads to the issue. Beyond that, I don't know enough about GeoServer's security to know what to change. I want the WFS and WMS in particular to be available to everyone, or better yet available to a select URL.

  • 2
    docs.geoserver.org/2.7.x/en/user/security/index.html would be the place to start. It would help to know if any formats work (e.g. is the problem just WMS and WFS) and if any layers work the way you expect. It would also help to know how you configured authentication (e.g. LDAP, internal, something else) and if the layers show up in the GetCapabilities response. Can you update the question with some more details please? Just click edit below the question. – BradHards Apr 5 '16 at 7:01
  • Did you ever figure this out? I'm having the same issue with an OpenGeo Suite installation. – mr.adam Jun 16 '16 at 0:15
  • @mr.adam I don't have the link anymore so I'm going by memory, but one of the guys who manages the package wrote that it behaves like that on purpose as a security measure -- only things imported through GeoNode will be served to the public by GeoServer. Anything imported through GeoServer on the other hand can only be viewed by those logged into GeoServer. He also wrote that it would probably be easiest to just install GeoNode and GeoServer independently and from scratch rather than trying to untangle those security settings. I personally just gave up at that point. Sorry. – CarlWinslow Jun 17 '16 at 2:21
  • @CarlWinslow, thanks for the info. In my case, I'm trying to use GeoExplorer, which comes with OpenGeo Suite, and can consume and transact WFS from a local GeoServer which is also included in the suite. Seems like maybe GeoNode and OpenGeo Suite have similar security configurations when it comes to this... – mr.adam Jun 17 '16 at 14:09
1

Did you set permissions to everyone when you uploded the layer? I had the same problem and it worked around setting "View permissions" to "anonymous" group (even when i don´t see a group named like that in the geonode group list). See if it works for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.