I am trying to export images from the QGIS print composer, the exported image has a basemap that is loaded from an XML file following this questions method. The export doesn't look at all like the image I see in the print composer see below and I'm trying to understand why.

What I'm trying to do is simply make a decent looking map without obvious tiling with readable labels. Perhaps I have to use a satellite only image and remake with my own labels. The map is a HERE nokia hybrid map

This is a jpeg at 150 dpi, note the tiny labels in comparison to the screenshot at the bottom This is a jpeg at 150 dpi.

This is a png export at 300 dpi, which is standard for the print composer, note the labels, and tiles. this is a png at 300dpi which is standard print composer

Finally, this is a screenshot of the map as it looks in the print composer with the labels readable at this zoom scale. This is a screenshot of the map as it looks in the print composer


What seems to happen is that the composer tries to print a larger map on a smaller area to go from 72dpi (assumed screen resolution) to 150/300dpi. It even looks like it zooms out automatically...

Try adding &ppi=320 as a URL parameter to the server URL. That should scale up the labels enough for your print resolution.

  • thanks, <ServerUrl>https://1.aerial.maps.cit.api.here.com/maptile/2.1/maptile/newest/hybrid.day/${z}/${x}/${y}/256/png8?app_id=dEKUTzncoRbyC15LuFgf&amp;app_code=6bk41pC1aTyaSrPVuTbEGg</ServerUrl> this is the xml i'm using. Any ideas where the &ppi=320 should go?
    – hselbie
    May 26 '16 at 0:03
  • Just right at the end, the same way you add app_id and and app_code: <ServerUrl>https://1.aerial.maps.cit.api.here.com/maptile/2.1/maptile/newest/hy‌​brid.day/${z}/${x}/${y}/256/png8?app_id=dEKUTzncoRbyC15LuFgf&amp;app_code=6bk41pC‌​1aTyaSrPVuTbEGg&amp;ppi=320</ServerUrl>
    – echom
    May 26 '16 at 5:33
  • 1
    Great stuff, it works like a charm depending on dpi specifications
    – hselbie
    May 26 '16 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.