5

I'm working on a wall map that needs to include labels for EVERY street and address range. I recognize that I will have to do a lot of editing to make it work, but I can't even get QGIS to put the labels on so I can edit them.

enter image description here

As you can see in the screen shot, I've chosen to show all layers, but the segments in blue, for example, aren't labelled even though they are separate lines with valid labels.

The other issue is that, of course, the map window and composer window are never quite the same.

I'm using the latest download (2.14.3).

  • Further down the "Rendering" screen, did you also check on "Label every part of multi-part features" (are they multi-part lines?) and check off "Discourage labels from covering features"? Also, on the "Placement" screen, you might try increasing the priority slider of the layer labels to "High". – RyanDalton Jun 24 '16 at 18:38
  • Yes, all of those. I've previously merged all line segments with the same name into a single feature as well. – marcp Jun 24 '16 at 18:58
  • There's another "show all labels for this layer" checkbox you could try out. On the window you have there, the label settings, in the top right there is a weird icon with a four direction yellow arrow thing. Press that and try some of the options in there. – SaultDon Jun 24 '16 at 21:25
  • right on, wasn't sure if it would work, will do – SaultDon Jun 24 '16 at 22:45
8

From the label settings window, there's another hidden spot where you can toggle all labels.

At the top right, click the yellow four-direction arrow button and place a check beside Show all labels and features for all layers.

Note that that will affect all layers, not just the one you're working with.

turning on all labels for all layers in QGIS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.