2

I'm using Ubuntu 14.04 with postgres-9.5 and postgis 2.2.2.

Previously I performed shp2pgsql-gui to access the interface, but now, the terminal shows me this message:

the program shp2pgsql-gui not installed in the moment. you can install
typing sudo-apt-get install postgis

The result of:

select * from postGIS_full_version()

is:

POSTGIS="2.2.2 r14797" GEOS="3.4.2-CAPI-1.8.2 r3921" PROJ="Rel. 4.8.0, 6 March 2012" GDAL="GDAL 1.10.1, released 2013/08/26" LIBXML="2.9.1" LIBJSON="0.11.99" TOPOLOGY RASTER

Does anyone know how I can solve this problem?

  • try the answers here gis.stackexchange.com/questions/148524/… – kttii Jul 12 '16 at 19:06
  • @kttii I had ever seen, but it did not work – Naldson Chagas Jul 12 '16 at 19:45
  • so you ran 'sudo apt-get install postgis' after the error you described above? did it produce any errors? – kttii Jul 12 '16 at 20:05
  • did you try 'sudo locate shp2pgsql' and was there any result? – kttii Jul 12 '16 at 20:07
  • please edit/update the question with your results after you try something else. – kttii Jul 12 '16 at 20:09
4

It seems that 'shp2pgsql-gui' is now part of the postgis-gui package

Try : sudo apt-get install postgis-gui

It worked for me.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.