41

I'm missing all the usual processing tools in the Vector menu in QGIS 2.16 (eg vector overlay, analysis, etc). They do appear in the processing toolbox but there's no sign of them in the Vector menu. Has anyone come across this issue?

  • This happened to me too and I realised there was two instances of QGIS running! – Michael Dec 6 '17 at 0:44
20

I had the same issue, first thought it was intentional, but discovered if you delete the .qgis2 directory from user account this fixes the problem. See https://hub.qgis.org/issues/15265

  • This worked for me! On QGIS 2.16.3 – wtgeographer Oct 17 '16 at 18:55
  • as scary as this may seem, it worked for me as well on 2.18.4! Thanks! – rickD Mar 21 '17 at 5:38
  • 2
    I had a similar problem of tools under the vector menu nor appearing on QGIS 2.18.3. I had QGIS 2.8.7 and 2.18.3 versions installed on a windows 10 system.The tools appeared on the 2.8.7 and was not on the 2.18.3 Followed this approach and deleted .qgis2 directory from my user account(directory or folder) and restarted it. It now appears on the 2.18.3 and still in the 2.8.7 – mapperx Mar 26 '17 at 19:44
  • 2
    In my case, uninstalling a plugin named "Processing" and restarting QGIS solved the problem. There was no need to delete the entire .qgis2 folder, with all the installed plugins and settings. – isshp Dec 5 '17 at 16:14
  • 3
    I just went to plugins->manage and install plugins, and selected the checkbox next to 'processing'. Activating this plugin made my vector tools reappear! – jOshT May 8 '18 at 16:53
34

According to https://hub.qgis.org/issues/15265, the GDAL tools might get lost if you have the processing tools installed as an external plugin.

Since some time, it has become a core plugin, so no need to be in the users .qgis2/python/plugins/processing folder. You can remove that savely.

Apart from that, I discovered a second Vector menue right to the Help menu, if my locale is not US English. Overriding the locale with US English puts them back together again.

  • Thanks - I had two versions of QGIS running (2.16 and 2.14). Uninstalled both and deleted any associated files including the above folder. Reinstalled 2.16 and the processing tools reappeared in the vector menu. – user77875 Jul 19 '16 at 7:38
  • 3
    I followed Casper Borgesen's advise on the issues link above and the old vector menu reappeared without uninstalling and reinstalling QGIS. I uninstalled the processing plugin (despite the scary warning) and then restarted QGIS 2.16. The processing tools reappeared in the vector menu and the processing menu and toolbox returned. – blackthorn Oct 6 '16 at 11:50
  • I removed the .qgis2 folder (which is then repopulated by QGIS on restart) as mentioned in the issues link above. That fixed the problem for me (the problem came after upgrading from 2.14 to 2.18, in ubuntu 16.04). – eglatorre Mar 20 '17 at 15:42
  • For QGIS 3.8 I did the following and it worked: rm -R $HOME/.local/share/QGIS/QGIS3/profiles/default/processing, restarted QGIS 3.8 and re-enabled the processing plugin from main --> plugins --> manage and install plugins – Dimitris 2 days ago
20

The fTools plugin offered these menus and it has been removed from QGIS and is replaced with the processing plugin.

Just enable the processing plugin and the menu will be back. Note that you can go to Processing => Options => Menus, to configure in detail which algorithms will be available in the menu.

fTools and processing both offered the same tools in the past. This resulted in a much increased maintenance overhead and regularly issues were only addressed in one of the the two.

Processing offers a lot more possibilities like a vast amount of additional algorithms, modelling capabilities and configuration, so it's really worth it!

  • Probably due to an update, I don't see the Menus option in Processing => Options => Menus, but I found the tools by going to Processing => Toolbox and then searching in the side panel. Thanks. – Cyrille Feb 15 '17 at 18:05
4

In my case deactivating and then reactivating the processing plugin in Plugins -> Manage and Install Plugins fixed the issue.

Everything is back on my Vector menu.

3

I've installed Qgis 2.16, the first time without tools because there were problems with PyQGIS libraries after uninstalled old versions. Then i decided to fully uninstall Qgis, deleted ".qgis2" folder in my Userprofile folder, deleted some keys related with Qgis in Regedit (Windows OS), cleaned OS and finally reinstalled Qgis without problems. Maybe certainly can be done in other method instead of this long boring way...

  • Which registry entries on Windows did you delete? Removing the ".qgis2" folder an all other folders related with OSGeo4W and QGIS did not help in my case (I'm using the OSGeo4W-installer). After re-installation QGIS still shows up with all its previous configuration (plugins, database connections, settings ...). For users with restricted registry access this is really annoying. – Michi Aug 3 '16 at 11:42
3

I had the same problem of having two vector-menus (my QGIS 2.18 (Ubuntu 16.04) set to Finnish): one that was actually in the language set for QGIS (Finnish) and other that was in English. The two menus together had all the vector functions that QGIS normally would have. This problem didn't occur when using QGIS set to English.

In my case, to lose the second vector-menu while using the QGIS set to Finnish, I had to: | Processing | Options > Choose "Reset to defaults" besides "Menus (requires restart)" and it worked (after restarting QGIS, of course).

0

I had the same problem to find the "points in polygons" entry in the Vector's menu, however with a little trick, I found a work-a-round, which immediately solved my problem. Here is the solution (sorry for the German menu, but you'll find the corresponding items): Menu: Ansicht>Bedienfelder>Werkzeugkiste (STRG+ALT+T) This brought a toolbar on the right side up--> then type points in polygons and select the item showing up, which brings a pop-up window for using the feature.

0

I had this problem in QGIS 3.8. I just went into manage and install plugins searched for processing, which is a core plugin. I unclicked this to disable the plugin and then reclicked to enable. This fixed the problem and vector reappeared on the toolbar.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.