1

I created domain range and added into my field. The range was 0-100, nevertheless I could fill 359 into the field.

Do you have any idea where is a problem? I am working with ArcGIS 10.4 for Desktop.

enter image description here

enter image description here

  • 3
    How are you entering the number? Field calculator or directly editing the field in an edit session? – Fezter Jul 21 '16 at 6:53
  • 1
    Please edit your question to include your method for entering the number 359 into the field. – Midavalo Jul 21 '16 at 7:23
  • I was directly editing the field in an edit session – Anna Juřicová Jul 21 '16 at 7:28
2

The issue here is that the domains do not prevent you from adding incorrect data into the fields. You need to validate the features first. To do this, you need to be in an edit session. Then, select the features you want to validate. If any of them are invalid, you'll get an error.

If you select a single feature and validate it, you'll get a more descriptive explanation of what's wrong.

For example, I have set up the same domain as you. I created two features with incorrect values. I have selected them:

enter image description here

In the editor toolbar, click on Validate Features:

enter image description here

It tells me I have two features which are invalid:

enter image description here

If I select the first feature, you can see that the explanation is more descriptive and tells me exactly what is going on.

enter image description here

Selecting the second feature:

enter image description here

Fixing the values, and running again:

enter image description here

Note, I would read more about the validation tool, as it validates more than just attributes.

This post has an answer which explains that you can use python to script a solution.

1

There is an option in Arcmap to validate the ranged domain once you enter the value. But in this case you have enter the value from the attribute table itself (NOT FROM THE ATTRIBUTE WINDOW) To Activate this Option follow the below steps after creating and assignee the Domain: 1- Open New MXD. 2- Go to ArcMap options from customize menu. 3- Click on tables tab 4- Check the option (automatically validate records when editing ) Tables Option in ArcMap Options 5- Open the attribute table and enter the wrong value (359) 6- You will get a warning massage that this value is out of range Waring Massage This option just validates the value and warns you in case of wrong value (NOT FOR PREVENTING)

  • Nice. I didn't know that. – Fezter Jul 27 '16 at 7:01
  • Welcom Fezter :) – M Fathy Jul 27 '16 at 9:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.