4

I'm having a problem that is universal to any shapefile that I'm trying to convert into a DXF with QGIS.

I've used the "Export DXF" option in the toolbar as well as the "Save As" option when right clicking the layer and neither will work. If I use the "Save As" the data will successfully export into a DXF file. The problem is when I try to open that DXF in AutoCAD. All of the information is there, but it's at a microscopic scale (1100 feet turned into something like .003). If I measure the same distance in the original shapefile in QGIS, it's spot on. I also just tried opening the DXF back into QGIS and that lines up perfectly as well.

I also tried scaling the drawing in CAD (not perfectly precise but just to get something workable) and it wouldn't scale correctly. If I choose two points and then specify a length it doesn't come anywhere near matching that length. It's almost like it's a difference between the "Length" measurement in the properties menu and the units being used to perform the actions (although I don't know of any units that scale to 1:5,000.

Does anyone know why this happens or how to work around it?

  • 1
    What QGIS version, what OS, what coordinate system? – nielsgerrits Aug 9 '16 at 18:55
  • 2.14.3 QGIS version Windows 7 - 64 bit WGS 84 As mentioned, if I open the DXF in QGIS, it lines back up with the data already in the project. It's when I open it in AutoCAD that the issue comes up. We've tried it with AutoCAD LT and Civil 3d. It's also not a uniform change of scale that you would associate with a unit switch. It's something closer to 1:4925. – H. Rigsby Aug 9 '16 at 19:06
  • Try using OGR from the Processing Toolbox to convert your shapefile to DXF format: Processing Toolbox > GDAL/OGR > [OGR] Conversion > Convert format – Joseph Aug 10 '16 at 11:19
  • EDIT: I chose the wrong tool. Will try again now. – H. Rigsby Aug 11 '16 at 13:35
  • Received this error message. I've never used this tool so I might be doing something wrong. I added the shp file to the map, added it as the input layer, changed the destination format to DXF and specified a file location and type (seemed redundant to specify DXF twice. – H. Rigsby Aug 11 '16 at 13:42
2

For use in Autocad, you should reproject into a projected CRS like UTM, with meters as units.

If your CAD project is using mm as units, you need to put up a custom CRS with +units=mm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.