2

I have hundreds of images in JPEG2000 format. I need to (in which ever order is best) mosaic, reproject and have my final file in JPG format. Dealing with 10-50GB of data per imagery files that need to be joined. Ideally, these need to be compressed to around 100MB to use in CAD.

I have tried a few different ways using FME. Somewhat successful but the image had white seams. So far the best methodology is: JPEG2000 > RasterInterpretationCoercer > RasterMosaicer > Reprojector > Geotiff (with 75% JPEG compression and TAB file of 64x64)

Still the image is not really easily rendered in any program.

Lots and lots of files needing to do this to so efficiency is important, but not at the expense of quality.

2
  • I've edited your question to prevent it being too broad. By asking a question and asking for answers in three products you are effectively asking three questions which goes against the Tour. If you still need to know about the others just research/ask about them in separate questions.
    – PolyGeo
    Sep 28, 2016 at 20:06
  • 100 MB as jpeg usually means 1GB or more as uncompressed and programs must uncompress the whole jpeg file before they can use it. I would not be surprised if they open slowly.
    – user30184
    Sep 29, 2016 at 4:25

1 Answer 1

2

I can offer some hints for FME.

When you say white seams do you mean along where each of the tile edges was? If you're mosaicking before reprojecting then I wouldn't expect that to happen. I've seen that but only when reprojection is before mosaicking.

That's assuming the JP2000 tiles are square to begin with (ie there are no areas of nodata around the edges).

Anyway, first suggestion is to make sure the parameter "Nodata Overwrites Data" is set to No in the RasterMosaicker.

Another transformer to try would be the RasterBandNodataSetter. Add one at the start of the workspace and enter the nodata value in there (I would imagine it is 255 if the seams are white, but also try 0)

Hoping that the combination of those two will solve the white seam problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.