1

I installed Semi-Automatic Classification Plugin but it doesn't work. After starting QGIS, program displays a message "Please restart QGIS to executing the Semi-Automatic Classification Plugin. Possible missing dependencies." Closing the program gets an error "Crush dumped", every time.

I can't uninstall or reinstall this plugin from plugins repositories interface, this also causes "Crush dumped".

I use QGIS 2.14.7 and 2.16.3. Windows 7 Pro 64bit.

  • 3
    Go to your .qgis2 directory and delete the plugin folder from there (e.g. C:/Users/You/.qgis2/python/plugins/. There have been 3 published updates to this plugin very recently so it could very well be that there was a bug and the author(s) addressed this. You could try previous versions of the plugin by downloading from their repository and extract the plugin folder from the zipped file and place it in the same location mentioned above. – Joseph Oct 13 '16 at 9:35
  • I did it with versions: 5.0.13, 5.1.1, master - without success. – Jadwiga Trojak Oct 13 '16 at 10:35
  • The version I last tested successfully was 5.0.10, maybe try that? I use QGIS 2.16.1 for Windows 7 64-bit. – Joseph Oct 13 '16 at 10:37
  • Unfortunetly, I have the same problem with this version. – Jadwiga Trojak Oct 13 '16 at 10:47
  • I installed QGIS 2.16.3 from downloaded files (not from advanced installer like before) and then Semi-Automatic Classification Plugin was installed correct. And it turns on. – Jadwiga Trojak Oct 13 '16 at 12:27
3

I have the same problem with ubuntu 17.04 and 17.01 running qgis las palmas. It was solved by installing python-matplotlib and python-scipy

sudo apt-get install qgis python-matplotlib python-scipy

For QGIS based on Python 3:

sudo apt-get install python3-scipy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.