I have a point shapefile where i need to transfer the records into a geodatabase feature class that is Point Z. I have found a number of processes to go the other way, removing Z value and make it a simple point, but I want to go the other way. I know I do not have Z values so wondering if this is possible and the points would just get a Z value of 0, or if Arcmap will just continue to give me errors when I try to convert. I tried enabling Z values in the geoprocessing environment menu and then did a Feature Class to Feature Class geoprocess, but it created the new feature class without Z values still.

Any suggestions?

1 Answer 1


sigh.... turned out to be an arcmap bug that a restart fixed. once i restarted, the feature class to feature class geoprocess with Environment Z values enabled worked and the points came out as Point Z

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.