2

I am currently working with a netcdf file which I export to a GeoTiff and then layer over a 3D globe, the problem is a get a white line showing up at the dateline, straight through the pacific. When I look at the data I see that the final line of pixels on the east (right) side of the netcdf and GeoTiff file is set to nodata, hence the white line. My question is how do I remove this line of nodata pixels and rescale (I'm not sure this is the right terminology) the raster so that its extent is exactly -180, 180, -90, 90?

Here are the details of what I am doing. I am opening the netcdf file with ArcGIS using the "Make netcdf raster layer". I extract the relevant data and export to a GeoTiff. I get the following extent: -179.999946594238, 179.846244812012, -90.0677337646484, 90.0219573974609 with 4320, 2160 columns and rows and a cell size of (x,y) 0.083297729, 0.083343506. I however want the extent to be exactly -180, 180, -90, 90 with 4320, 2160 columns and rows and a cell size of (x,y) 0.0833333, 0.0833333. I have tried changing the extent in the layer properties, as well as, changing the raster size or cell size when exporting the GeoTiff. Nothing seems to work.

0

Using gdal_translate with -a_ullr option set to -180 90 180 -90 ended up fixing the problem for me, if anyone else has the same problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.