1

I'm developing an ArcMap add-in that takes some specific data from our database, generates some new layers on the map, then populates a multi-select box within the add-in.

All of that was largely working until yesterday. I did some updates to the geoprocessing, which seemed to work, but the population of that multi-select seemed to break (which was very odd, as I know where the code to do that is, and I didn't touch it).

Anyway, I monkeyed around with it for a while, to no result, and finally tried going back to an older version of the code where that part was known to work. And it didn't.

Even stranger, it turns out that this select box is populated; you just can't see what's there. But you can click on it, and the behavior is what is expected.

Some further experimentation this morning revealed that I can't run it on a co-worker's computer (running the same copy of the add-in off a shared drive). Even starting a new .mxd on her computer did not help; not even without a base-map layer present (so I know that has nothing to do with it).

However, the co-worker can run it on her computer.

Another bit of weirdness is that the progress bar window that opens up during the processing is truncated on her computer, but not on mine (and again, this is with an older version of the software that worked correctly a few days ago).

When something works for one person, but not another, my thinking immediately goes to permissions, but a) I didn't change any permissions yesterday and b) I don't even know what permissions might possibly have this kind of effect.

Anyway, I'm fairly new to ArcMap programming, and was hoping someone here might have some clue what's going on, preferably with a new avenue to approach to try to figure out what's going on. At this point, I'm not even sure what to try to isolate the problem further.


@danielm suggested exactly the sort of thing that I was hoping for. Unfortunately, deleting the normal.mxt only forced me to re-add the toolbar for the add-in. The cache certainly sounded promising, but I was unable to find that. c:\Users\%user%\AppData\Local\ESRI\Desktop10.3 does exist, but its only contents are the folders ArcCatalog and Configuration. And a drive-wide search on c: for AssemblyCache turned up nothing. Am I looking in the wrong place?


Actually, maybe deleting the normal.mxt did work. I logged out and logged back in (I'm not aware of anything else I did in the meantime), shortly after posting that, and it is now working.

closed as off-topic by PolyGeo May 8 at 10:42

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

4

If something in ArcMap should be working and isn't there are a couple cuprits that crop up regularly.

  • First check out %AppData%\Roaming\ESRI\Desktop10.X\ArcMap\Templates\Normal.mxt. Back that file up and delete it.

If that doesn't help sometimes when installing an ArcMap add-in it won't overwrite an old install correctly. From what you've described I'd say this is what's happening when you rolled back to the old version.

  • Go to %LocalAppData%\ESRI\Desktop10.X\AssemblyCache there will be a whole bunch of folders named after the UIDs of your installed add-ins, find the one for your add-in, delete the whole folder and reinstall the old version of your tool. See if that helps.

The AssemblyCache folder is a hidden system file. You can access it by either showing hidden system files in the Windows folder options or typing the folder name into the address bar.

For specific issues you'll need to post code relating to that issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.