1

I am having a problem trying to get maps to print to a specified scale.

Goal: to print a map to scale so that an engineer's scale (ruler) can be used to measure features on the printed map.

Problem: After setting the map scale to the desired scale and adding a scalebar linked to that map, the scale bar does not measure out correctly.

Here is an example of my issue: The page size is 8.5 X 11 inches but scalebar does not measure correctly. The scale bar unit is set to feet but the label multiplier is 0.083333 (1/12) and the number of right segments is 11 (for 11 inches), so it should display the full width of the page.

enter image description here

I have seen several other posts with the same issue, but none of them have been answered.

How can I get maps to print to a specified scale?

Here is a new map create after verifying printer settings are not set to 'fit to page', it has a line feature that is 500 ft in length but does not measure that on the printed map, from direct print, pdf or image. enter image description here

  • So you just want a ruler printed along with your map? The scale bar is going to be dependent upon the scale of the map item. You might try setting your scale bar to "fit segment width" and specify a value of 25.4 mm (1 in). – JoshC Mar 2 '18 at 21:09
  • What are the other questions with the same issue that you have already reviewed? – PolyGeo Mar 3 '18 at 0:01
  • @JoshC - No, I don't want a ruler printed on my map, the example was just to show that when trying to create a printed map to scale it is not correct. I will try the fit segment width as you suggest to see if that works. Thanks. – Kelly McGee Mar 3 '18 at 17:13
  • @PolyGeo, I looked at "Printing 1" scale from 2.8.2 Print Composer", "Qgis scalebar shows wrong scale", and one other that I forgot to write down. – Kelly McGee Mar 3 '18 at 17:16
  • @JoshC - Based on my map scale and scalebar settings (all listed on my uploaded image) the scalebar should have should have stretched the full width of the page but it does not. I was following the example from the post "Printing a 1" scale from 2.8.2 Print Composer" post. here – Kelly McGee Mar 3 '18 at 17:36
1

I think this is actually an issue with your printer; it's probably set to 'print to fit' rather than 'print actual size', and so it's scaling your map when you print. It's likely something that takes place after your map has left the program; try printing as an image file of some sort (.pdf, .tiff,. jpg) from your GIS, and then printing the image.

  • I randomly print maps in scale and I can confirm this answer. QGIS is doing fine! The "miss scaling" is a part of the printer settings and/or the PDF-Reader/image Programm. – MAP Mar 3 '18 at 9:36
  • @Mox, I thought the same thing, so I checked that to make sure that it was not set to 'print to fit'. This issue was brought up at one of my clients and I suggested the same thing, and I even checked that when I visited them. See my second comment to JoshC on my question. I will double check this again though. Thanks. – Kelly McGee Mar 3 '18 at 17:53
  • Printers are wily beasts. It may not be just 'print to fit', but some sort of scaling where the ink would dirty the printer, hence the manufacturing adding a 'secret scaling factor' to prevent people from printing off the edge of the page. – Mox Mar 5 '18 at 17:14
  • @Mox, I fully agree with your comment that printers are wily beast. Both myself and my client have verified that all settings have been checked. – Kelly McGee Mar 8 '18 at 21:10
  • @MAP, you state that you are able to print maps to scale in QGIS, can you possibly provide a sample or perhaps your map and scalebar settings? I really need to figure this out. Please see my Update comment in the original question. Thank you. – Kelly McGee Mar 8 '18 at 21:18
1

I just solved my own maps not printing to scale issue it had to do with CRS settings between the project and the grid I was adding to my map. I had problems getting my grid and scale bar to match and measure correctly when printed. I discovered that my project was in WGS 84 / pseudo-mercator while the grid was in WGS84/UTM zone 10N. Once I changed the CRS in the map project and the the grid both to WGS84/UTM zone 10N the scale bar and grid are now to scale when printed. This problem likely stems from a lack of knowledge about CRS settings and conversions, I am sure others can explain in detail what the issue is.

I ran across this post many times and my issue was not a printer problem so I hope this may help someone with a similar issue. So if you printer settings are correct and you are still having issues with things not lining up check your CRS settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.