2

I have many point shapefiles all in WGS84 and I need to project them to different Coordinate systems. Every shapefile has only one point with its coordinates and the EPSG number for which the point is to be projected to.

Example Shapefile Attribute Table

So I've created a little Iteration in the ModelBuilder.

enter image description here

The Value is stored as "Coordinate System". But unfortunately I get the following error at the projection part.

Executing (Project): Project D:\David\Verarbeitete_Daten\Preprocessing\koord_Select\Wtrsh_9.shp D:\David\Verarbeitete_Daten\Preprocessing\Koord_proj\Wtrsh_9.shp PROJCS['WGS_1984_UTM_Zone_60N',GEOGCS['GCS_WGS_1984',DATUM['D_WGS_1984',SPHEROID['WGS_1984',6378137.0,298.257223563]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]],PROJECTION['Transverse_Mercator'],PARAMETER['False_Easting',500000.0],PARAMETER['False_Northing',0.0],PARAMETER['Central_Meridian',177.0],PARAMETER['Scale_Factor',0.9996],PARAMETER['Latitude_Of_Origin',0.0],UNIT['Meter',1.0]] # GEOGCS['GCS_WGS_1984',DATUM['D_WGS_1984',SPHEROID['WGS_1984',6378137.0,298.257223563]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]] NO_PRESERVE_SHAPE # NO_VERTICAL
Start Time: Wed Apr 18 11:53:55 2018
ERROR 999999: Error executing function.
invalid extent for output coordinate system
Failed to execute (Project).
Failed at Wed Apr 18 11:53:55 2018 (Elapsed Time: 0.01 seconds)

What is the reason for that?

  • You say the point is stored with it's EPSG number and I assume that is what the Get Field Value tool is extracting, but your screen shot shows the whole spatial reference string, so it converting the number on the fly? Might help if you edit your question to show a screen shot of your input data (attribute table)? – Hornbydd Apr 18 '18 at 10:39
  • 1
    @Hornbydd I've added the Attribute Table of an example point. – David Apr 18 '18 at 10:45
  • 1
    Where is the Point located? Could it be outside the bounds of epsg 32660? Does it succeed with any of the Points? – BERA Apr 18 '18 at 10:53
2

Try Get Field Value with output set as Spatial Reference, then feed this into the Create Spatial Reference which will connect to the output coordinate system for the Project tool. I tried it with Iterate Feature Selection and it is working.

Model

If this does not work check where is the Point located. It might be outside the bounds of epsg 32660.

  • 1
    I was answering this question but @BERA beat me to it! :) I constructed the same model and it worked well for me too. So as hinted above in the comments the extent issue may be due to you trying to project the point into a coordinate system where it is not. – Hornbydd Apr 18 '18 at 11:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.