1

When trying to install install contour plugin for QGIS Wien on Linux mint I get error "The contour plugin is disabled as it requires python modules numpy, matplotlib, and shapely which are not all installed".

the software required does not seem to be available in the repos and version would be important as well. Any one know the fix?

3

The error is outlining what you need to do. The plugin needs numpy, matplotlib and shapely to be installed in your system.

Try going to software manager from Menu > Administration > Software Manager and then in the search box type those three names and it should appear straight in your software list. Install these python libraries one by one and then try to reinstall the QGIS countour plugin. It should work. You can restart your system if the installed plugins are not recognised.

matplotlib search result in Linux Mint Sofware Manager

  • Thanks I was using synaptic but package manager was clearer – lewis May 11 '18 at 0:49
  • @lewis pelase mark the answer as accepted if it helped you: gis.stackexchange.com/helpcenter/someone-answers – AndreJ May 14 '18 at 6:41
  • So marking as accepted is not so obvious. – lewis May 15 '18 at 20:53
  • Besides I like an air of mystery. – lewis May 15 '18 at 21:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.