1

I've plotted several locations based in Auckland, New Zealand, using Grid NZGD2000:ESPG:2193. When I load QuickMapServices and set to the same grid, The basemap produced is situated off Omen. enter image description here

  • 1
    I doubt the problem comes from QMS. I would rather think your data is misplaced. Check your data source projection. If possible, publish some examples of X/Y values. – gisnside Jun 18 '18 at 7:53
  • How do you "set to the same grid"? If the basemap is in EPSG:3857, you better leave it in tthat CRS. Do the layers align if you set the project CRS to EPSG:3857? – AndreJ Jun 18 '18 at 11:09
  • I just change it in properties. When left as default, no basemap shows up. X/Y shown below: 5920705 1755253 5918819 1753290 5932578 1753626 5976580 1755875 5912447 1763803 – RF1 Jun 18 '18 at 23:07
3

Per the comments, you're doing it wrong.

You can't simply change a layer's CRS if it was defined as another.

How to resolve: Make sure your layer in the original EPSG:2193 CRS.

If after you load the basemap, the canvas doesn't change to EPSG:3857, change the canvas to EPSG:3857, and zoom to your layer's location in New Zealand.

| improve this answer | |
  • Thanks for your comment but basemap still not showing even when set at 3857. I'll have a play around with it but can't see what i'm doing wrong at the moment. – RF1 Jul 1 '18 at 21:41
  • Update: updating to the new version of QGIS solved the problem. – RF1 Jul 25 '18 at 21:35
1

You mentioned in the comments that updating to the new version of QGIS solved the problem. I assume you updated from a 2.x version to a 3.x version.

The solution to your original problem would have been to turn on "on-the-fly reprojection." This feature allows multiple layers in different CRS to be displayed as if they were all in the same CRS without creating a new version of each layer.

In the QGIS 2.x series, on-the-fly reprojection was an option that could be toggled in the project properties. In QGIS 3.0 and later, on-the-fly reprojection is always on. That's why updating to the new version of QGIS solved your issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.