I'm trying to add a custom basemap, created in Mapbox, to Quickmapservices in QGIS. However, the layer won't load and it keeps showing an error message:

Error: Layer xx can't be added to the map!

Filling out the Quickmapservices new WMS service form I've added: -The URL for the WMTS link to Quickmapservices found at the bottom of 'share map' in Mapbox. - The layer name (rather than the layer title), which I found by adding the basemap to QGIS through 'add WMS layer' first.

Does anyone know what might be going wrong? I've checked the QMS FAQ and haven't found an answer. Is it that a WMTS link won't work with WMS? Do I need to add any formatting to the link?

enter image description here

  • 1
    Why not just add it through the regular QGIS "Add WMS/WMTS layer" tool? Nov 9, 2017 at 13:42
  • What does the error say?
    – nmtoken
    Nov 9, 2017 at 13:46
  • The error is "Error: Layer xx can't be added to the map!". I would quite like to get it working in QMS as it's a quick and handy way to add in different layers - especially for my colleagues who are less advanced at QGIS
    – mrblanco
    Nov 10, 2017 at 9:33

2 Answers 2


After experimenting and looking at other QMS options I've found a potential workaround. You can use the leaflet URL (at top in photo below) with the "create TMS layer" option in QMS. This seems to work okay with the other default settings.

If anyone has a way to get WMS working, or can think of any problems with using TMS it would be interesting to know.

Using the leaflet options as a TMS layer seems to be a workaround


I know this is several months old but thought I'd add a bit for future reference:

I was able to add a customized MapBox style to QGIS 3.0.2 as a WMS source using the WMTS endpoint provided by MapBox (as in your screenshot included above). Instructions are here.

Note that it's important to set the project CRS to the CRS listed in the Information section of the the MapBox layer's properties. If you don't, the layer will still draw but it will appear to be of unusably poor quality.

  • can you add the link?
    – RutgerH
    Oct 2, 2018 at 15:15
  • Ah interesting, I'll try that next time. Thanks Holly
    – mrblanco
    Nov 2, 2018 at 15:23
  • @RutgerH Sorry... don't know what happened to the original link but I've added it back. May 14, 2019 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.