0

I've added a Mapbox WMTS layer to my QGIS project.

However when I use the print composer and export my map the result is blurry / not sharp. The image in the print composer itself is sharp, it is only after export that the problems occur. Any idea how to solve this? I've also tried exporting as PDF but the result is the same low quality.

I also tried increasing DPI and total number of pixels but the results are disappointing.

enter image description here

  • Is your QGIS project in the same CRS as the Mapbox layer? Projecting a tiled layer into a different CRS can result in blurry labels. – csk Oct 2 '18 at 17:32
  • Yes Both Web Mercator – RutgerH Oct 3 '18 at 7:30
2

The Mapbox WMTS endpoint only supports @1x resolution, but in QGIS 3 you can add an XYZ Tiles source and use the @2x resolution Mapbox tiles. Something like

https://api.mapbox.com/styles/v1/USERNAME/STYLE_ID/tiles/256/{z}/{x}/{y}@2x?access_token=ACCESS_TOKEN

If you're happy for your icon/text to become smaller you can get even more resolution by requesting 512 @2x tiles instead of 256 tiles

https://api.mapbox.com/styles/v1/USERNAME/STYLE_ID/tiles/512/{z}/{x}/{y}@2x?access_token=ACCESS_TOKEN
  • Where did you find the information about the XYZ mapbox tiles? – RutgerH Oct 3 '18 at 8:59
  • The problem is that the map is only unsharp after export. Before export resolution is fine. – RutgerH Oct 3 '18 at 9:09
  • mapbox.com/api-documentation/#retrieve-raster-tiles-from-styles under "Retrieve raster tiles from styles" – AndrewHarvey Oct 3 '18 at 12:28
  • Sure, this might not be the issue, it's just a suggestion. – AndrewHarvey Oct 3 '18 at 12:33
  • I've also come across this problem - it seems to relate to the tiles being pulled in when you export at a zoom level that is different that what is seen in the composer window. I can get around by it setting the min and max zoom levels (in my case to 2 and 6, respectively); by also increasing the resolution per the answer above it seems to somewhat get around the problem for me. – scabecks Jan 17 at 23:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.