0

I'm trying to compile CGAL libraries on fedora 27 but when I compile them using cmake ,it show's the following message:

CMake Error: Unable to open check cache file for write. /home/xx/Documents/CGAL-4.11/build/CMakeFiles/cmake.check_cache
CMake Deprecation Warning at CMakeLists.txt:22 (cmake_policy):
  The OLD behavior for policy CMP0042 will be removed from a future version
  of CMake.

  The cmake-policies(7) manual explains that the OLD behaviors of all
  policies are deprecated and that a policy should be set to OLD only under
  specific short-term circumstances.  Projects should be ported to the NEW
  behavior and not rely on setting a policy to OLD.


== Setting paths ==
Build CGAL from release in directory CGAL-4.11
Packagenames: CGAL-4.11
== Setting paths (DONE) ==

== Generate version files ==
CMake Error at CMakeLists.txt:275 (message):
  File VERSION or include/CGAL/version.h are missing, required by
  release-build.

any help ,please ?

  • This may be more on topic on Stack Overflow, since it's probably more to do with cmake or your compiler toolchain than CGAL itself. In any case: where did you get the sources? (git, source rpm, etc.) And, how did you run/configure cmake? – Evil Genius Jun 27 '18 at 11:26
  • I downlaod cgal package from the official site ,and other prerequisites libs (eg:boost,gmp,..) from dnf package manager – n.m Jun 27 '18 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.