I downloaded QGIS MacOS installer version 3.2. I downloaded and installed Python 3.7 as instructed before I started the installation of QGIS. I was able to install GDAL but when I try to install QGIS I get the error message that says "QGIS requires Python 3.6."

Does this mean I need to install an earlier version of Python?

If so, which version should I install?

I see there are multiple versions of Python 3.6.


1 Answer 1


The minor version matters, it must be 3.6. The patch version usually does not (3.6.N), but QGIS.org specifies 3.6.5 as a minimum.

You can not use Python 3.7 or non-python.org distributions (note: some people have reported mucking around with symlinks to mimic a standard python.org 3.6 install path to get python 3.6 from homebrew/anaconda working).

From the download instructions on QGIS.org:

This package uses the python.org Python 3.6, at least version 3.6.5, the "macosx10.9" build - other distributions are not supported.

As of today, the package you need is:

Python 3.6.8 - 2018-12-24 macOS 64-bit installer (NOT the macOS 64-bit/32-bit installer).

  • I missed that "fine print". Thank you so much. It worked! Aug 4, 2018 at 13:56
  • This should be marked as answer Jan 22, 2019 at 13:03
  • As of today, version 3.6.8 is the current one. Answer should point to python.org/downloads Jan 25, 2019 at 11:48
  • @TelmoPimentelMota you are welcome to edit questions here.
    – user2856
    Jan 25, 2019 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.