1

EDIT: Solved, see my answer.

I've downloaded 8 MOD44B granules from Reverb (using the FTP script method), and am trying to use MRT to mosaic them. I'm falling at the first hurdle though - when I add the 4 files (4 from 2000, 4 from 2007) I get an error saying firstly One of the input files does not exist or the inputs are not the same data product type then Input file does not exist!. If I add files individually, I get an error saying Error in Module: ReadHrFile, Opening Input Header File.

Has any one had this error before, or know how to fix it? I've updated Java and reinstalled MRT.

Versions:

  • MRT: 4.1 (March 2011)
  • Windows: 7
  • Java: 6 (Updated to 7, still doesn't work)

I would use the online interface, but I need MOD44b which isn't available with that for some reason.

closed as off-topic by PolyGeo Feb 28 '17 at 8:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    For future reference, there is a web-based version of the tool called MRTWeb that lets will let you download mosaicked MODIS data without having to download get the source HDF files. This is useful if you're doing a time series analysis. – dmahr Jul 16 '12 at 12:02
  • Thanks for the suggestion dmahr, although I did try this - see the bottom of my question. MOD44B is unavailable using MRTWeb for some reason (as far as I could tell). – gisol Jul 16 '12 at 14:16
2

You need to open ModisTool.BAT rather than the ModisTool.JAR executable. Silly me. Least I have nice new versions of everything running now.

1

You can open the ModisTool.bat on Notepad and edit.

In last line it has the Java localization with "java.exe" two times. You need erase the last time and save it.

1

You need to run the .bat file by right clicking -> run as administrator. To prevent this error, install MRT by running command prompt as an administrator.

The error won't occur if MRT is installed in drive other than c:

Not the answer you're looking for? Browse other questions tagged or ask your own question.