2

I have a project where I am making a lot of rule based labels from a polygon layer. The layer is saved as a shapefile (like the other label-layers (point and linestrings). All other layers in the project is saved in a database (PostgreSQL).

I have made the layer with no symbology and a lot of rule based labels, where only a small part is active.

When I turn the layer on, it overrides all other layers with a black color. The more I zoom out the more of the data frame it covers in black. It looks like this:

When the layer is turned on:

And when the layer is of it looks fine:

When the layer is turned of

Does anyone know why I have this problem on a polygon layer, but not on the line or point layers, with the same settings? And does anyone have a solution?

  • With such a clear border it seen unlikely but if some of your labeling setting are off (like some very large label or label with very large black buffer...) you may end up with an opaque layer so you may want to check that everything is as it should be (no oversize thing or wrong unit)... – J.R Apr 15 at 11:51
  • Thx. But I just feel like I have been through all settings - but I am not very skilled with these things (yet ;) ) . If i remove the labelling from the layer the problem disappear. – DyndeMachine Apr 15 at 12:23
  • 1
    As I said the perfectly straight line of the black part suggest another problem (no idea what it could be) but if one of the text size, buffer or background is set to the wrong unit (for exemple it should be 500 Meters at Scale but is set as 500 Millimeters) you may get something like this. You could also open a new QGIS doc, import your label layer and copy/paste the label style to check if the problem still persist. – J.R Apr 15 at 12:49
  • Thank u so much. I have been so many settings through, and the problem was on of the many labels was set to inches instead of map units. Thank u. Problem solved. :) – DyndeMachine Apr 15 at 13:07
1

If one of the text size, buffer or background is set to the wrong unit (for exemple it should be 500 Meters at Scale but is set as 500 Millimeters) you may get something like this.

You could also open a new QGIS doc, import your label layer and copy/paste the label style to check if the problem still persist.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.