1

I have an aerial image (.jpg format) of a relatively small site and have been trying to georeference it and generate a corresponding .tif file. I followed several online tutorials, but I keep getting an error "Transform Failed: Failed to compute GCP transform: Transform is not solvable."

Here is a screenshots, of the QGIS Georeferencer:

enter image description here

And for reference, here are the locations & coordinates of the ground control points used:

enter image description here

Multiple transformation types were used (Thin Plate Spline, Projective, Linear), the resampling method is nearest neighbour, and "Set target resolution" is unchecked.

I wonder if the problem lies in the fact that QGIS truncated the ground control points coordinates (as shown in the table in first screenshot) or some sort of issue with the coordinates format I used (Degrees - Minutes - Seconds).

I also tried fixing the ground control points directly against Google Maps Satellite images via the QGIS QuickMapServices (QMS) tool, but got the same error message.

Would anyone have an idea how I could properly georeference this aerial image?

(Note: this is not for commercial use, only a school project).

  • QGIS may really truncate the WGS84 coordinates too early which could lead into identical locations for all your ground control points. A workaround could be to convert the GCPs from EPSG:4326 into some system that is using meters as units for example with gdal.org/programs/gdaltransform.html#gdaltransform. – user30184 Jun 24 at 15:08
  • Will look into it. Thank you! – Reivilo444 Jul 1 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.