2

I am trying to publish TIFF in GeoNode. The TIFF file has a .tfw file.

Uploading directly from GeoNode fails. Then I uploaded to server and published it in GeoServer and it works in GeoServer. I want the layer to be available in data panel in GeoNode. For this I did geonode updatelayers but it gives ('Failed to process geotiff_coverage', AttributeError("'Coverage' object has no attribute 'srid'",))

Then I saved the image as GeoTIFF using QGIS (i.e. without .tfw file) but still same problem.

0

You probably need to set the projection (that's what the error message is saying). Try creating a .prj file to go with the .tif and .tfw files if you already know the projection. http://epsg.io will be able to show you what goes in it.

Alternatively, when saving out of QGis be sure to make sure that there is a CRS set for your layer.

  • I tried both method but still same errors – neogeomat Jun 25 at 13:40
  • can you publish it directly in GeoServer with out GeoNode? to work out where the error is? – Ian Turton Jun 25 at 14:23
  • i can directly publish to geoserver and it works from there, but it doesnot appear in the geonode data panel – neogeomat Jun 25 at 15:00
0

The default workspace in geoserver was changed so it didnot work. Setting geonode as default workspace solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.