1

I am using QGIS version 2.18 (I know newer versions are available, but I would like to try and fix this!) and have a problem with the projection changing unexpectedly.

I would like to use OSGB 1936 /British National Grid (ESPG:27700) and I set this using Project Properties > CRS > Apply. In order to set this, I have to enable OTF transformation - otherwise all options except a custom projection (USER:100000) are greyed out. If I turn OTF transformation back off, it sometimes remains in British National Grid but sometimes reverts back to another projection.

I have also had issues when adding files. This sometimes causes the projection of the project to change. I'm used to having to change the projection of the file itself, but not the whole project.

I use QGIS regularly and this problem does not occur on my usual computer. However, it seems to occurs on a computer that I use occassionally at another location (which I did not set up). I feel like an underlying setting may not be working correctly.

How can I force QGIS to stay in my projection of choice, particularly if the Project Properties route isn't working for this?

4
  • what sort of files are you adding? the only time I had the projection change is when I added background maps using the QuickMap plugin
    – Ian Turton
    Jul 2 '19 at 15:16
  • Why are you turning off OTF reprojection? You need this setting on unless all your layers are in the project CRS.
    – csk
    Jul 2 '19 at 18:56
  • Type of files - MID/MIF in this particular instance. Usually I would expect to have to change the CRS of the individual file, but not for adding that file to change the projection of the project.
    – Battenburg
    Jul 4 '19 at 10:55
  • OTF reprojection - interesting question! To be honest I think this just stems from the person who trained me in QGIS suggesting that I shouldn't use it. I've just clarified with them why that was and, as we typically want everything in the same projection, keeping this turned off avoids the issue of, say, the reprojection of one file not quite working. So perhaps there was just a bad experience once and switching off OTF stopped that happening.
    – Battenburg
    Jul 4 '19 at 10:59
4

If you go to Settings > Options > CRS, you can set ESPG:27700 to be the default CRS when starting new projects or adding new layers:

CRS options

1
  • I would also add that if you have the 'Use Project CRS' for new layers set, any new layers that are not in the project CRS will look odd and potentially help debug any layer-related CRS issues that might be associated with OP's problem.
    – nr_aus
    Aug 17 at 0:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.