0

I am by no means an expert in ArcGis, but I will try and explain my problem as clearly as possible.

I am analysing forest cover data from the Hansen land-cover dataset ( data https://earthenginepartners.appspot.com/science-2013-global-forest/download_v1.2.html) to estimate the proportion of forest cover around multiple lake surface samples taken from the same lake.

Map with multiple buffers at various km intervals around one of my sample points To treat this dataset I needed to mask the water component. This is because the water and the not forest (signified by the black in the map below, with the forest white)were both given the value of 1. Therefore, when originally extracting my data, a not forest value of 20% could have signified that 10% of the data in an individual buffer was represented by water, rather than the targeted not-forest.Image of my map below with the buffers for one data point

I created a series of buffers, using the multiple buffer tool, around each one of my lake surface samples ( 0.1, 0.5, 1-10 km).

To determine the stats for the forest/not forest in each one of these buffers I used the zonal statistics as table tool. This produced a table for my data but only with the statistics from one of the buffer zones.

For using the zonal statistics, I used the multiple buffer shapefile output and the masked landcover map as my raster.

Since I have 15 lake surface samples, I could do each one of the buffer zones independently and extract the data using the statistics tool but this is extremely time-consuming. I notice that when I am selecting the Zone field option, I select the FID option because it is the only option to select that has different values for each individual buffer (Latitude/Longitude and Site name are equal). See below for the options selected

Multiple buffer attribute table, and zonal statistics tool choice selection

As mentioned, I gave this a test run before I went about to mask the water data and it produced the zonal statistics in the way in which I wanted them. i.e in one table, I would have the zonal statistics for each of my buffers rather than the current situation where I am only getting one statistic for all the buffers.

2

If I look at your question, it seems that one of your polygon is selected. Make sure that you unselect it in order to run on all features.

Also, I recommed to make copy of your FID field in a new column and use this column as a zone field. FID could change when you edit or export data. This can be done with the field calculator.

Another thing to watch is the actual resolution used by arcgis in the analysis. Make sure to fix i to 30 meter in the environment variables of your tool.

Finally, create buffer for all polygons in different shapefiles (dissolve option at "none") and run them one after the other (right click on the tool and select "batch", because overlapping polygon are not wel managed by zonal statistics (which internally converts into raster, which means that only one value can exist for a given pixel.

  • Hi, thank you very much for your comment. I made a new Field with the calculator with a simple FID*1 formula and no improvement on the results. I think I will just go with your idea of the batch running and add each buffer point individually. I was unable to explode the multi-part feature of the buffers tool in the editing section with the error that no multi-part features are selected, even though all buffers are under the same feature shown in the above attribute table. – Adam Bermingham Aug 27 at 14:19
  • "because overlapping polygon are not well managed by zonal statistics (which internally converts into raster, which means that only one value can exist for a given pixel." - That is the heart of the issue, you cannot have overlapping polygons on zonal statistics, an alternative is to use focal statistics which combines the buffer and statistical summary into a raster output which you can extract to your original points. – RGfromRWBJV Aug 27 at 20:38
  • Thank you very much for your advice. – Adam Bermingham Aug 28 at 7:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.