1

I am wondering, where I could make the mistake seeing the wrong result, which is coming from the Viewshed plugin in QGIS. There are a few options, I selected the "Viewshed", which looks like this: enter image description here The map generated doesn't match with the same visibility map generated by Heywhatsthat.com service:

enter image description here

enter image description here

whereas the altitude of the point is 172 m.a.s.l. My data attribute table looks as follows: enter image description here

and accordingly the .csv file, from where my data comes from:

enter image description here

I put height as a m.a.s.l. value, observer height as a 2 meters above ground, radius - 5km.

To be honest I don't understand from where this result comes from.

I found some answer here: Interpreting viewshed results attribute table

but it doesn't solve my problem, as it refers to the intervisibility analysis.

Can anyone help?

EDITED:

After the brief DEM conversion done here: Raster -> Conversion -> Translate (Convert format)

I am still getting the wrong result, as per below:

enter image description here

I found a similar problem here:

How to reproject a raster in QGIS?

and I tried this, however the major problem is the target CRS selection:

enter image description here

This is admittedly optional, although without any choice I am getting exactly the same result as above.

After selection the EPSG 27700 OSGB British National Grid 1936 or alternatively another one from Great Britain, I am getting nothing after the Viewshed processing.

enter image description here

  • Did you try Processing > Toolbox > GRASS > Raster > r.viewshed? See also grass.osgeo.org/grass78/manuals/r.viewshed.html – markusN Feb 12 at 22:32
  • Target CRS may be optional, but if you don't choose one, your data won't get reprojected. You need to know what is an appropriate projected CRS to use. Please don't modify your question so it is essentially a different question now, particularly after someone has answered so the answer no longer completely applies. – user2856 Feb 19 at 0:03
2

Your data is unprojected, i.e. it's in EPSG:4326 a geographic coordinate system (CRS) not a projected CRS.

From the documentation:

Input data

  • Digital elevation model: terrain model in a raster format (a pixel grid such as .tiff). Only projected raster data can be used. Latitude/longitude “projections”, such as WGS84 are not allowed.

    ...

[I repeat: do not use unprojected data in degrees (Lat/lon, WGS 84), such data is inappropriate for precision calculation. Be sure to understand GIS projections before mailing me…]

Reproject your data to an appropriate projected CRS for your area.

  • Thank you for your hint. I tried the projection and it looks slightly better. Unfortunately, it looks like the projection requires to do something more. I have updated my query pointing, where the problem is. Do you know, which "Target CRS" shall I choose in order to get this result correctly? Any hint cordially appreciated. – Mariusz Krukar Feb 18 at 11:30
  • 1
    I don't know anything about UK CRSs, perhaps this will help gis.stackexchange.com/q/74651/2856 – user2856 Feb 18 at 20:32
  • I tried to do this. Unfortunately, I am getting nothing as per the updated query above. Thank you for a hint anyway. – Mariusz Krukar Feb 19 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.