0

I was able to use osm2pgrouting tool successfully on Windows with PostgreSQL version 11.9 and pgRouting version 3.1.0. I successfully generated my "ways" file in a PostGIS conection in QGIS 3.10.3.Now I want to test a Dijkstra algorithm with the pgRouting Layer plugin, but I constantly get a Python error, as follows:

File "C:/Users/jorge/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\pgRoutingLayer\pgRoutingLayer.py", line 1255, in openHelp
          db = self.actionsDb[dbname].connect()
         KeyError: ''
         

I am already connected to my postgres DB through DB Manager of QGIS but in my pgRouting Layer dialogue box, I am never "shown as connected" to my postgres DB as shown in following figure. I tried to press refresh button and drop down list many times but no use. I've also saved my user and password in my DB connection, but it haven't solved my problem.

enter image description here

  • All your software versions look very much outdated, many of them not supported anymore. I would strongly suggest you to first try newer versions! – dkastl Aug 29 at 3:43
  • With what user are you trying to connect? – Iman Aug 29 at 20:23
  • @lman the user I tried to connect is "postgres" – Jorge Fuenzalida Izquierdo Aug 30 at 0:43
  • @dkastl I'm sorry, I misspelled the versions. My postgis version is 3.0.2 and my pgrouting version is 3.1.0. My PostgreSQL version is 11.9 – Jorge Fuenzalida Izquierdo Aug 30 at 0:57
  • As per the help center it is OK to try and reproduce software problems in a Q&A here, but if you think this is a bug then be sure to submit it to the pgRoutingLayer development team. Please post a link to the bug report here. – underdark Oct 4 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.