2

I tried to download some shapefiles data from here and the layer is shown correctly, however when I open the attribute table I can see just the number of rows but not the rows themselves and when I click organize columns no fields are detected, any tip on how to see the data in the attribute table?

The version of QGIS I am using is from the arch Linux repositories and my OS is Manjaro Linux if this can help.

enter image description here

5
  • There should be a box at the lower left of the attribute table where you can toggle between showing selected features or all features. Maybe you are set to only show selected features but no features are selected? – GBG Mar 31 at 18:22
  • Does this answer your question? Transparent color of Selection in Attribute Table Related to your black theme I think – ThomasG77 Mar 31 at 19:42
  • @GBG It is on the option "show all features" by default so that was not the problem – Chel Del Formai Mar 31 at 21:26
  • @ThomasG77 unfortunately that's not the case, i tried to change themes but with no luck, plus in the post you linked the author could actually see the rows but they were empty and i don't see even those in my case – Chel Del Formai Mar 31 at 21:28
  • Can you also add a screenshot in your question of idt2.regione.veneto.it/idt/downloader/download with selected options so we can get the exact same data source? Could help – ThomasG77 Mar 31 at 22:56
5

It looks like you have a filter on. I can't see your whole attribute table from the screenshot. But, if you go through that dropdown menu in the bottom left of the table and select Field Filter or Advanced Filter (Expression) you may notice you have one on, or an expression set. In your screenshot it shows Features Total: 382, Filtered 382. General Tools. enter image description here

1
  • 1
    "Features Total: 382, Filtered 382" actually means "unfiltered". All 382 features passed the filter. It confuses me sometimes too. – wingnut Apr 7 at 5:06
3

The solution was that the .shp file name was in uppercase while the .dbf file and the .shx file were not.

After renaming the files accordingly in lowercase the table is shown correctly.

0

Things to try:

  1. There should be a .dbf file with the attributes in the same folder as the .shp file. If not, that's the problem. Download again.

  2. Delete the layer from QGIS. Copy the .dbf file to another folder. Then drag the new copy into the layer panel in QGIS. You won't see a layer on the canvas, but you will see an icon for the table in the layer panel. Open its attribute table. If you see attributes but no information, it's a problem with QGIS (ie a display issue due to filtering etc).

  3. Dark Theme - turn it off and check again

  4. Download another area from the same site. A layer downloaded from that site does appear to work. Maybe yours has bad attribute data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.