2

Is it possible to load the services in https://staging.gcm.telstra.com.au/gisserver/rest/services/Hosted into QGIS.

I have tried a Virtual Layer, Vector Tile and ArcGIS Map/Feature service with no luck.

In https://crowdsupport.telstra.com.au/t5/network-roaming/gis-layer-of-telstra-mobile-coverage/td-p/893241 a poster mentions that QGIS 3.14 can't load the format (PBF) but is it possible in newer versions and if so how?

3

Yes, it is possible, using vector tiles and use the URL like this one (tested with QGIS 3.16):

https://staging.gcm.telstra.com.au/gisserver/rest/services/Hosted/Wholesale_4G_3G_High_Contrast/VectorTileServer/tile/{z}/{x}/{y}.pbf

enter image description here

4
  • This loads but doesn't seem to be correctly projected. For example when I add a basemap WMS feed the data doesn't show. Is there a way to change/check projections on the telstra vector tile as properties shows no CRS etc? The info is there when you go to the page directly in a browser. gisservices.information.qld.gov.au/arcgis/rest/services/…
    – GeorgeC
    Apr 22 at 1:17
  • from the metadata it should be 3857. on my map it lies in australia and fits to OSM more or less..
    – eurojam
    Apr 22 at 5:43
  • Did you try to zoom in - it disappears when I try and doesn't match with the QLD WMS feed I linked above. When I go to it's properties it doesn't show any projection info but in the page it does have 3857 - staging.gcm.telstra.com.au/gisserver/rest/services/Hosted/…
    – GeorgeC
    Apr 22 at 5:53
  • yes it is strange...I remarked this with the disappearing...sorry but no further ideas on that
    – eurojam
    Apr 22 at 12:11
1

Yes, just add it as a Vector Tile Server.

In a web browser, go to https://staging.gcm.telstra.com.au/gisserver/rest/services/Hosted, select your layer, eg. Mobile_All_Outdoor, right click and copy the URL:

https://staging.gcm.telstra.com.au/gisserver/rest/services/Hosted/Mobile_All_Outdoor/VectorTileServer

Go to QGIS (I'm using 3.18), open the Browser panel, right click "Vector Tiles" and select "New ArcGIS Vector Tile Service Connection..."

enter image description here

<!DOCTYPE connections>
<qgsVectorTileConnections version="1.0">
    <vectortile zmin="0" referer="" name="Mobile_All_Outdoor" serviceType="0" authcfg="" password="" username="" styleUrl="" url="https://staging.gcm.telstra.com.au/gisserver/rest/services/Hosted/Mobile_All_Outdoor/VectorTileServer" zmax="19"/>
</qgsVectorTileConnections>
3
  • When I do this I get an error `Invalid Data Source: serviceType=arcgis&type=xyz&url=staging.gcm.telstra.com.au/gisserver/rest/services/Hosted/… is not a valid or recognized data source.' . When I use @eurojam's answer I can't zoom in. Can you save and send me the xml of the connection.
    – GeorgeC
    Apr 24 at 2:50
  • Unfortunately it doesn't load. I was using 3.16 and am just updating but can you send the xml from the save tab when you go to Vector Tiles?
    – GeorgeC
    Apr 24 at 6:52
  • 1
    It works in 3.18. It would have helped if you'd specified your version in your qestion.
    – user2856
    Apr 24 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.