This is a very basic question, but as I've self-taught most of my GIS skills this is still a gap in my knowledge.

When I load a .tif raster into ArcMap, most of the time it requires re-exporting to get it to display the correct values on the colour ramp. Rather than the actual values, I get 255->0 for most .tif files. Why does it default to this scale? And is there any way to get ArcMap to display the actual pixel values first time?

Thanks in advance,


In ArcGIS you need to 'calculate statistics' for your raster. The easiest way to accomplish this is to right-click on your raster in the table of contents and select Properties. Click on the Symbology tab and you will have access to your display and symbolization properties. From here you can select the symbology you want to use. If you switch between Stretched and Classified in the left-hand pane Arc will prompt you to calculate the raster statistics. Once the statistics are calculated your data should display properly. At this point you can switch back to Stretched if you like. This is a trick to get it calculated quickly.

enter image description here

Alternatively, you can use the Calculate Statistics tool, which is found under Data Management in ArcToolbox. The default values are fine.

On a related note, statistics should be calculated automatically in most cases if you have it set this way in the Environment Settings under the Geoprocessing menu:

enter image description here

| improve this answer | |
  • Very nice! Just what I wanted. Thanks for the quick symbology trick too. – JPD Nov 27 '12 at 16:52
  • 1
    I usually do this in ArcCatalog, in my experience ArcMap sometimes hangs or crashes when doing it through the Symbology tab if the raster is large. – Dan C Nov 27 '12 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.