4

enter image description hereSince I updated from QGIS 3.16 to 3.22 I have the following problem in attribute tables: in gpkg files the sorting option (alphabetical) does not work - sometimes!

I tried it with projects in qgz- or qgs-format. It happens with point-layers and with polygon layers.

Mostly the problem occurs in gpkg layers, seldom also in shapefiles. The problem only happens in string fields, not in integer/real fields. What is the problem, is it a bug?

Now I added a screenshot. In my OS ubuntu 20.04 up to QGIS 3.16 I sorted by single click, everytime it worked, when I clicked single on the top of a field in the attribute table. Now for example in this table a single click (or double click) works for the field "name_lat", but not for the field "name_d", neither with "jahr". All three fields are string fields. With fid it works.

Now I tried another way: there is a possibility for sorting, but more complicated. When I click on the top of the attribute table, choose context menu, choose sorting. Then I can choose the field for sorting the attribute table. So it works, but it is really complicated. Up to QGIS 3.16 it worked just by one click on the field name that is relevant for me.

Look here https://github.com/qgis/QGIS/issues/47613

6
  • 1
    You mean sort by double-clicking the column name?
    – BERA
    Mar 9, 2022 at 11:53
  • 1
    I have done a quick test in 3.16 and 3.22 and the data sets I used sorted fine, doesn't mean there isn't an issue.
    – Sethinacan
    Mar 9, 2022 at 13:19
  • Yeah, you probably have to provide a bit more context: how does you attribute table look like, how do you sort and how does the result look like?
    – Babel
    Mar 9, 2022 at 13:40
  • 1
    I also think there's something going on with the attribute table sort. Sometimes I can double-click the column name and nothing happens in 3.24
    – BERA
    Mar 10, 2022 at 6:24
  • I’ve never needed to double-click a column head to sort in an attribute table, but I can confirm that this sorting problems exists in 3.24. I didn’t notice this in previous versions.
    – bkepl
    Mar 12, 2022 at 18:53

1 Answer 1

2

The bug is fixed in QGIS 3.22.5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.