2

I am currently setting up a qgis server with lizmap on ubuntu-server 20.04.4, only that, on the lizmap webapps server information tab, it says "QGIS Server returns an HTTP error about the Lizmap plugin: 500". I declared /usr/lib/plugins as plugin-directory in the apache conf

  #PluginPath
  FcgidInitialEnv QGIS_PLUGINPATH "/usr/lib/qgis/plugins"

then I installed the plugin 'Lizmap server' as lizmap_server (and many others) in the declared directory with qgis-plugin-manager.

[email protected]:/usr/lib/qgis/plugins$ qgis-plugin-manager list

QGIS server version : 3.10.4
List all plugins in /usr/lib/qgis/plugins

---------------------------------------------------------------------------------------------------------------------------------------------------------------
|  Folder ⬇        |  Name            |  Version  |  Flags            |  QGIS min  |  QGIS max  |  Author                   |  Folder rights  |  Action ⚠              |
---------------------------------------------------------------------------------------------------------------------------------------------------------------
|HelloServer       |HelloServer       |version 1.2|Server,Experimental|3           |            |Alessandro Pasotti (ItOpen)|root : 0o755     |Unknown version|
|atlasprint        |atlasprint        |3.3.1      |Server             |3.10        |            |3Liz                       |root : 0o755     |               |
|cadastre          |cadastre          |1.14.2     |Server,Processing  |3.4         |3.99        |3Liz                       |root : 0o755     |               |
|lizmap_server     |Lizmap server     |1.0.1      |Server             |3.10        |3.99        |3Liz                       |www-data : 0o755 |               |
|lizmap_server2    |Lizmap server     |1.0.1      |Server             |3.10        |3.99        |3Liz                       |root : 0o755     |               |
|wfsOutputExtension|wfsOutputExtension|1.7.0      |Server             |3.0         |            |3Liz                       |root : 0o755     |               |
---------------------------------------------------------------------------------------------------------------------------------------------------------------

Different rights have been detected : 'root : 0o755','www-data : 0o755'. Please check user-rights.

As of htop, the mapserv.fcgi process is executed by the apache2 user www-data, thats why I changed the owner of one of the plugins to www-data:www-data, without success.

I also tried changing the whole directories owner to www-data or root without effect.

Lizmap Webapp says that Qgis server is correctly installed, so I don't think that my problem is IP or /etc/hosts related, which doesn't mean it's impossible. Lizmap and QGIS are on the same Virtualhost, as the server is only for internal use.

The error message is

QGIS Server is correctly installed and returns the expected response for OGC requests.

We cannot get the details about your QGIS Server installation (version, plugins, etc.). Either the version of the installed QGIS Server is under 3.10, or the Lizmap plugin is not detected in your server, or is installed with a version under 3.7.0. Please upgrade QGIS Server to minimum 3.10 and install or upgrade the Lizmap plugin to minimum 3.7.0 by reading the documentation about the environment variable https://docs.lizmap.com/current/en/install/pre_requirements.html QGIS Server returns an HTTP error about the Lizmap plugin: 500

5
  • Did you read the documentation link provided and the note about the "Lizmap server" plugin ?
    – etrimaille
    Jun 30, 2022 at 16:14
  • Side note, "3.10.4" is pretty old, even for a 3.10 series. This version was released March 2020. The latest 3.10 is 3.10.14 which was released january 2021. Are you really using QGIS desktop 3.10 ?
    – etrimaille
    Jun 30, 2022 at 16:16
  • Also check QGIS server logs when you are requesting the page from Lizmap Web Client, you might have clues.
    – etrimaille
    Jun 30, 2022 at 16:18
  • Also, you must remove lizmap_server2 it looks this plugin will make a conflict with lizmap_server
    – etrimaille
    Jun 30, 2022 at 20:02
  • I have the same problem using NGINX and a virtual environment for the qgis-plugin-manager. Did you resolve it with the answer below? gis.stackexchange.com/questions/473638/… Jan 6 at 14:43

2 Answers 2

2

I had the same issue (Ubuntu 22 and Apache 2.4) until I set the environment variables in /etc/apache2/mods-available/fcgid.conf instead of the site config files. e.g.

  <IfModule mod_fcgid.c>
  FcgidConnectTimeout 20

  <IfModule mod_mime.c>
    AddHandler fcgid-script .fcgi
  </IfModule>
  FcgidInitialEnv QGIS_SERVER_LOG_FILE /var/log/apache2/qgislog.txt
  FcgidInitialEnv QGIS_SERVER_LOG_STDERR 0
  FcgidInitialEnv QGIS_SERVER_LOG_LEVEL 0
  FcgidInitialEnv QGIS_PLUGINPATH /usr/lib/qgis/plugins/
  FcgidInitialEnv QGIS_SERVER_LIZMAP_REVEAL_SETTINGS 1

</IfModule>
0

You must install only plugins you need for your application, your own purpose.

HelloServer documentation mentions "Do not use it in production". Source https://plugins.qgis.org/plugins/HelloServer/

If you are using Lizmap, only install plugins listed on this web page : https://docs.lizmap.com/current/en/install/pre_requirements.html#qgis-server-plugins

if you are not French, you can also remove "Cadastre".

Install other plugins only if you know this plugin well and you know how it works.

On QGIS desktop, plugins can slow down your computer. On QGIS server, plugins are like hooks into QGIS server, they can alter input or output of QGIS server. They can produce unexpected result if you don't know how the plugin works.

You should also remove "Lizmap server 2" as this plugin will make conflict inside QGIS server with "Lizmap server" and generate errors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.