It's fairly simple, I'm making a print-layout for my map in QGIS. For spacing reasons, I'd like my legend to be below my map in two columns. However, The length of the layer's label stretches the column, so I guess I'd like the layer's label to not be a part of the 2-column setup. Is this possible, or would I be better served using something like Adobe Illustrator? See image:

enter image description here

  • 3
    Have you tried removing the long title from the legend entirely and adding it in as a separate text object?
    – Spacedman
    Commented May 12 at 18:24
  • That's a very good suggestion. I tried removing the long title, unfortunately QGIS keeps the vertical spacing of the entries, so the right column still starts above the left. I tried setting the spacing and font size of the group and sub-group labels to 0, but that only slightly shrunk the distance rather than eliminating it altogether.
    – Phil
    Commented May 13 at 7:13
  • Actually, I just found the answer to my problem in this thread. I just had to set the text to hidden.
    – Phil
    Commented May 13 at 7:32

1 Answer 1


The answer to this question was simply to right click the title element and set it to "hidden". More details can be found in this thread

Not the answer you're looking for? Browse other questions tagged or ask your own question.