I am trying to get a Vehicle Routing Problem to work as a geoprocessing service on one of our servers.

I used the default_date with unix time stamp in miliseconds and set the times of orders and depot in the format of "10:00 AM UTC". Now I get a time constraint violation for the orders ("ViolatedConstraints": 32)

If I take out the line "MaxViolationTime1":0 from the orders in my REST url, a route is calculated with correct travel times and distances and I can see the results. Especially the following lines (attributes of output route) caught my eye:

"TotalCost": 42.5174562651664,
"RegularTimeCost": 42.5174562651664,
"TotalTime": 42.5174562651664,
"TotalOrderServiceTime": 20,
"TotalTravelTime": 22.517456265166402,
"StartTime": 1369180800000,
"EndTime": 1369183351047,
"TotalViolationTime": 30.35018770210445,

I can change the default date and the earliest/latest start time, but the route starts still on the current date, at 2 AM. Could it be that some date and time options are "hard coded" somewhere in the module that was used to create the geoprocessing service? I checked the module again and can't find any options to change default date and time settings.

1 Answer 1


The parameter value should be specified as a numeric value representing the milliseconds since midnight January 1, 1970.

Default is in minutes:

Use this parameter to specify the time units for all time-based attribute values specified with different parameters. The parameter is specified using one of the following values: Seconds, Minutes, Hours, Days.

Many parameters in the vehicle routing problem request have attributes for storing time values, such as ServiceTime for the orders parameter and CostPerUnitTime for the routes parameter. To minimize data entry requirements, these attribute values don't include units. Instead, all time-based attribute values must be entered in the same units, and the time_units parameter is used to specify the units of those values.

Example request:


Full documentation: (ArcGIS 10.2 preview)


  • The time units are actually already correct. If I add "time_units=Minutes", nothing in the outuput changes. The "StartTime" date still differs from the default_date. May 23, 2013 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.