This is a result of mosaicing of two Landsat 7 images (layer stacked) in TIFF format. enter image description here

I was aming to put these images together with no overlaping visible line between them.

The process was: Added raster layers (two tiff files) then Raster-Miscellaneous-Merge then input files and then named the output file in Tiff format. Where is my mistake? I use QGIS 1.8.0.

  • Can you provide a download URL for the images? What layer and project CRS have you assigned?
    – AndreJ
    Commented Nov 29, 2013 at 9:25
  • 1
    Have you tried building a virtual raster in qgis instead? Menu Raster > Miscellaneous > Build Virtual Raster.
    – Jakob
    Commented Nov 29, 2013 at 11:37
  • @AndreJoost I downloaded images from USGS website. The images were layer stacked and have 1-5 and 7 bands. I have checked my files now one file has Datum - WGS 84 Zone 42N and another one is WGS 84 but Zone 43N. I am going to put the same CRS and layer project. Thank you!
    – Sasha
    Commented Nov 29, 2013 at 12:43
  • @Jake No, I haven't tried it yet but will try it. Thank you.
    – Sasha
    Commented Nov 29, 2013 at 12:44

2 Answers 2


For mosaicing rasters, it is necessary to use the same CRS for layer and project.

Otherwise, you get your images rotated and squeezed with black borders after transformation.

This might be eliminated by setting the transparency to the black color, but this might affect the image too.


In QGIS high resolution landsat images have to be processed before merging. Try this Raster> Miscellaneous> Build Virtual raster

Set the input and output files and proceed. See the screen shot

enter image description here

enter image description here

  • I think this step is not necessarily for merging raster.
    – Oto Kaláb
    Commented Mar 6, 2017 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.